Как в PDF сделать гиперссылку

Как вставить ссылку в pdf. Онлайн сервис PDFescape

Всем привет! У меня возникла такая необходимость как вставить ссылку в pdf документ, свою партнерскую ссылку. Существуют программы, и бесплатные в том числе, для создания pdf документа, но нужно было вставить ссылку именно в уже готовый документ, предоставляемый автором партнерской программы.

Для редактирования pdf файла надо PDF редактор Adobe Acrobat. Но программа это платная, к тому не дешёвая. Можно, конечно, поискать в интернете ключи, но…

В поисках решения попался онлайн сервис для редактирования и создания ПДФ файлов — PDFescape.

Интерфейс на английском языке. Если не понятно, войдите через браузер Chrome и переведите страницу. Сервис предоставляет такие возможности:

  • создание нового pdf-документа;
  • просмотр файлов;
  • редактировать файлы;
  • вставить изображения;
  • вставить ссылки;
  • создавать формы;
  • защита pdf-файлов паролем.

Как вставить ссылку в pdf документ

Загружаете файл. Можно загрузить файл с компьютера и с интернета.

Чтобы вставить ссылку в pdf текст или картинку выбираете пункт link. Зажимая левую кнопку мышки обводите необходимое слово, изображение. В выпадающем окне указываете ссылку на страницу в интернете, либо на страницу в этом же документе.

Слева в панели выбираете Сохранить и загрузить.

Установка гиперссылок в PDF

У многих возникала задача, когда необходимо в какую-либо печатную форму, сохраняемую в PDF, установить гиперссылки на какой либо сайт. Особенно актуально при сохранении различных коммерческих предложений и печатных форм заказов. Часто заказчик хочет, что бы в документах устанавливались гиперссылки, например на конкретный товар на сайте по коду или ещё что то подобное. В данной статье я постарался представить как можно сохранить обработать табличный документ, что бы на выходе получить файл в формате PDF с программно установленными гиперссылками.Первое что надо понять, у бесплатной Adobe Acrobat Reader нет API для программного редактирования гиперссылок. Есть только у платных Fine Reader и Professional. Поэтому, для решения этой задачи придётся воспользоваться Excel который стоит на большинстве компьютерах конечных пользователей.

Статья не претендует на уникальность информации, она лишь объединяет разные разобщенную информацию по данной тематике, что позволит, вероятно, сэкономить кучу времени..

Алгоритм установки ссылок в PDF будет следующим:

1. сохраняем табличный документ в Excel стандартными методами

2. Обрабатываем получившийся файл Excel, устанавливаем гиперссылки

3. Экспортируем Excel файл в формат PDF средствами Excel

4. Удаляем ненуженый файл Excel. Можно и не удалять — кому как нравится 🙂

Пример кода установки гиперссылки в колонку «код»:

MSExcel = Новый COMОбъект(«Excel.Application»); MSExcel.Visible = ложь; ExcelДокумент = MSExcel.WorkBooks.Open(АдресФайлаПолный); MySheet = ExcelДокумент.Worksheets(1); Для Каждого ПоискПозицииКолонкиКод Из MySheet.Range(«A1:P100») Цикл Если ПоискПозицииКолонкиКод.Text = «Код» Тогда СтрокаШапкиКод = ПоискПозицииКолонкиКод.Cells.Row; Колонка = Сред(ПоискПозицииКолонкиКод.Cells.Address,2,1); // вряд ли колонка код «убежит» куда то за двузначную нумерацию колонок AB, поэтому читаем 1 символ xlCellTypeLastCell = 11; Количество = MySheet.Cells.SpecialCells(xlCellTypeLastCell).Row; НачинатьС = СтрокаШапкиКод+2; Для Стр =НачинатьС По Количество Цикл Количество = Количество — 1; Попытка //попробуем перевести значение в число, если это код — сработает, если строка — нет ЗначениеКода = Число(MySheet.Cells(Стр, Колонка).value); Если ЗначениеКода = 0 Тогда // пустая строка Продолжить; КонецЕсли; Ячейка= MySheet.Cells(Стр, Колонка); СтрокаURL = «http://www.rambler.ru/goods/»+Формат(ЗначениеКода,»ЧГ=0″)+»/»; MySheet.Hyperlinks.Add(Ячейка,СтрокаURL,,); Исключение Продолжить; КонецПопытки; КонецЦикла; КонецЕсли; ОбработкаПрерыванияПользователя(); КонецЦикла; Состояние(«URL адреса заполнены»); ExcelДокумент.Save(); ExcelДокумент.Close(); MSExcel.Quit();

В Excel проставить ссылки в нужные места достаточно просто, с помощью метода

Hyperlinks.Add(Ячейка,СтрокаURL,,)

Затем начинается самое интересное. Открываем Excel, видим что всё в нём хорошо, можно бы и напечатать и пересохранить в PDF. Да, но! необходимо помнить, что Excel в PDF просто так не сохраняет, по стути, происходит печать в PDF. И, как следствие, получившийся файл PDF будет выглядеть безобразно. Для того что бы этого не происходило, необходимо обработать Excel таким образом, что бы печать из него по умолчанию, без каких либо настроек принтера была верной.

В зависимости от задачи для этого можно установить в параметры печати «вписать все столбцы на одну страницу», установить узкие поля.

Пример кода:

MSExcel = Новый COMОбъект(«Excel.Application»); MSExcel.Visible = ложь; ExcelДокумент = MSExcel.WorkBooks.Open(ПутьКФайлу); MySheet = ExcelДокумент.Worksheets(1); MySheet.PageSetup .Zoom = False; //отключает фактический размер страницы MySheet.PageSetup.FitToPagesWide = 1; //если поставить FitToPagesWide =1 и Zoom = False — будет «вписать лист на одну страницу», параметр FitToPagesTall в таком случае не использовать! MySheet.PageSetup.FitToPagesTall = False; //если поставить FitToPagesWide =1 и Zoom = False и FitToPagesTall=False — будет «вписать все столбцы на одну страницу» // а если поставить FitToPagesWide =1 и Zoom = False и FitToPagesTall=true — будет «вписать все строки на одну страницу» ///настройки «Разметка страницы — поля «узкие». Можно указывать и в сантиметрах, например, CentimetersToPoints(1,5) /// вообще, с этими настройками можно поиграться пока файл не приобретет нужный вид MySheet.PageSetup.LeftMargin = MSExcel.InchesToPoints(0.25); //левое MySheet.PageSetup.RightMargin = MSExcel.InchesToPoints(0.25); //правое MySheet.PageSetup.TopMargin = MSExcel.InchesToPoints(0.75); //верхнее MySheet.PageSetup.BottomMargin = MSExcel.InchesToPoints(0.75); //нижнее MySheet.PageSetup.HeaderMargin = MSExcel.InchesToPoints(0.3); //верх. колонтитул MySheet.PageSetup.FooterMargin = MSExcel.InchesToPoints(0.3); //ниж. колонтитул ФайлПДФ = СтрЗаменить(ПутьКФайлу, «.xlsx», «.pdf»); ExcelДокумент.ExportAsFixedFormat(0, ФайлПДФ , 0); //непосредственное сохранение в PDF. Первый параметр — тип файла (0= PDF), второй — путь к файлу и третий открывать файл после экспорта или нет MSExcel.ActiveWorkbook.Close(0); //закрываем без записи изменений MSExcel.Quit();

Подробно, с API и методами работы с MS Excel можно познакомиться на MSDN

Приветствую всех!

Возвращаясь к теме создания PDF-документов, хочу открыть небольшие секреты создания документов с навигацией. Не хотел делиться такими сведениями, ну да ладно, может быть кому-то сильно надо….

Что я подразумеваю под навигацией. Это когда в документе работают все гиперссылки на внешние источники, а также работают все внутренние ссылки.

Так как, чаще всего такие документы делают не для печати, то для большего удобства требуется сделать этакий минисайт: ссылки на главы pdf-книги, то есть должно быть работающее оглавление. Так же, очень удобно, когда имеется возможность с любой страницы книги или pdf-документа, не терзая судорожно при этом колесо мышки, а просто нажав на кнопку или ссылку “К содержанию”. А еще, желательно, чтобы были “хлебные крошки”. Пусть неактивные, но, по крайней мере, можно было бы понять в каком месте документа находишься.

Ничего особенного в данной технологии нет, я думаю многие знают эти приемы. Но есть нюансы. Итак…

Постановка задач

Требуется сделать PDF-документ или PDF-книгу так, чтобы в ней была удобная навигация. А именно:

  • Оглавление
  • Возврат к оглавлению

Задачи довольно элементарные, когда знаешь принцип и есть соответствующие инструменты под рукой.

Инструменты

Во-первых, и в основных, для создания пдф-файлов, с работающими в них ссылках, требуется всего одна программа, а именно Microsoft Word. С помощью нее можно делать практически любые pdf-документы. Все зависит от версии и некоторого терпения. Но желательно, Word версии не ниже 2010, а еще лучше 2013. Благо стоит она сегодня, сущие копейки, где-то в районе 250 рублей полный пакет программ Microsoft Office.

Во-вторых, опять Word, но версии 2007. Как бы не смешно это звучало, но нужно именно два разных Word. Чуть позже объясню, почему так…

Если денег жалко, то можно использовать Open Office или подобный пакет программ. Кстати, в данном бесплатном пакете отличный инструментарий для создания pdf-файлов. Прямо-таки, комбайн.

Имейте в ввиду, если используете для создания pdf-документов Open Office, то требуется изначально верстать документ в данном бесплатном приложении. Можно и из Word готовый документ перекинуть, но все сделанное ранее форматирование может “поплыть”.

Еще можно использовать Adobe Acrobat Pro, но это уже из области бессмысленно потраченных денег. Хотя можно и его использовать, расставляя ссылки вручную.

Процесс создания навигации

Допустим, имеется некий документ. Для примера, взял свою же статью про яндексдиск, просто собрал ее в Word.

Я уже писал в статье про книги с перелистыванием, что для создания правильного документа требуется использовать заголовки стилей. Как говорится, “повторенье — мать ученья”, так что не не надо плеваться в мою сторону. Я быстро пробегусь по процессу автоматической сборки оглавления и открою один маленький секрет для работающих ссылок.

Самое главное — это использование заголовков, все остальное делается в три щелчка мыши.

Устанавливаем курсор в нужном месте страницы или на отдельной странице, как у меня. Заходим на вкладку ССЫЛКИ и нажимаем кнопку ОГЛАВЛЕНИЕ. В выпавшем меню выбираем “Автособираемое оглавление 1”.

Оглавление готово. В получившемся оглавлении должны работать ссылки. Это важно.

Проверить работоспособность ссылок можно наведя курсор на пункт оглавления. удерживая Ctrl. Рука появилась? Значит ссылка работает, можете нажать и вас “перекинет” к нужному пункту содержания.

Маленький секрет

По сути, все эти переходы в Word реализованы с помощью гиперссылок. Да-да, как на обыкновенной интернет-страничке. А потому, если ссылки в оглавлении вдруг не работают, то идем Ссылки –> Оглавление –> Настраиваемое оглавление.

В открывшемся окне установите галочку “Гиперссылки вместо номеров страниц”. Вот теперь, у нас не просто номера страниц, а ссылки. Как правило данная опция установлена по умолчанию, но вдруг…

Возврат к оглавлению

Ну что ж, оглавление есть, делаем возврат к нему с каждой страницы документа. Процесс не сложный и занимает, буквально пять минут. Это при наличие Word 2013, если у вас ниже версия, то там по-другому надо будет делать. Но об этом, чуть позже…

Итак, делаем возврат к оглавлению.

Первое действие

Для начала, вернемся к готовому Оглавлению и сделаем закладочку, говоря языком HTML, сделаем правильный анкор (якорь). Это нужно для того, чтобы программа понимала куда ей возвращаться.

Выделяем нужное слово, в моем случае – это слово “Оглавление”. Заходим во вкладку Вставка – Ссылки – Закладки.

Даем название закладке. Например, “Содержание”

Нажимаем кнопку Добавить. Если смотреть документ в режиме отображения скрытых знаков, то у вас в выделенном слове появятся квадратные скобки.

Есть, закладка. Приступаем к следующему действию…

Второе действие

Делаем возвратную ссылку. Для этого будем использовать колонтитулы.

Колонтитулы — это такие отступы на листе: сверху, снизу, справа и слева. Поля страницы. Их можно использовать, да и используют, для размещения различной информации (номера страниц, сноски, примечания и тому подобного).

Заходим на вкладку Вставить – Нижний(Верхний) колонтитул – Изменить нижний (верхний) колонтитул. Или можно просто двойным щелчком мыши по нижней части страницы открыть колонтитул.

Пишем слово для возврата, например, “К содержанию” и добавляем гиперссылку на нашу закладку.

Нажимаем Ок и готово. Получили обратную ссылку к оглавлению.

Создаем PDF-документ с навигацией

Здесь все элементарно, ничем не отличается от того процесса, что я описывал в вот в этой статье. Меню Файл – Экспорт – Создать документ PDF. Даем название файла и сохраняем.

Смотрим, что получилось. Вот файл, можете сами убедиться, что все ссылки работают.

Еще раз повторюсь, сделать нормальную навигацию в PDF-файлах не особо большая проблема. Потребуется:

  • Желание, что-то сделать хорошо
  • Microsoft Word 2013
  • Умение использовать колонтитулы

А теперь, внимание!

Я не зря упоминал, что такие вещи позволяет сделать только Word 2013. Пробовал делать возвратные ссылки через колонтитулы, во всех существующих вордах. Ни один из них, кроме Word 2013, не поддерживает ссылки в пдф-документах.

В исходном вордовском документе, вроде все работает, а конвертируешь в PDF, и как “корова языком” все ссылки слизывает в колонтитулах. Нет их и все тут, причем все остальное форматирование остается, текст в колонтитулах остается, а ссылок нет. Почему так происходит, я так и не понял. Чудеса да и только. Если знаете, почему так и как это исправить в Word 2007, напишите мне в комментариях.

Хотя Word 2007 не поддерживает ссылки в колонтитулах, зато он может одну интересную штуку, которую не может Word 2013. Но это уже тема другой статьи…

Всем удачи! И не забудьте подписаться на новости…

Всегда ваш, Абрамович Артем.

При просмотре PDF-файла в Adobe Acrobat Creative Suite 5 вы можете добавлять ссылки для адресов электронной почты, веб-адресов , и ссылки на другие страницы. Ссылки привязаны к области страницы, которую вы идентифицируете с помощью инструмента «Ссылка».

Чтобы добавить интерактивную ссылку в документ PDF, выполните следующие действия:

  1. Найдите область страницы, на которой вы хотите добавить ссылку, а затем выберите «Просмотр»> «Панели инструментов» → «Расширенное редактирование», чтобы отобразить панель инструментов «Расширенное редактирование».

  2. Выберите инструмент «Ссылка», затем нажмите и перетащите, чтобы выбрать регион, к которому вы хотите привязать.

    Появится диалоговое окно «Создать ссылку».

  3. Выберите действие, которое будет выполнять ссылка:

    • Перейти к просмотру страницы : этот параметр является значением по умолчанию, где вы можете прокручивать страницу, являющуюся местом назначения ссылки.

    • Открыть файл . Кроме того, вы можете выбрать ссылку на другой файл; нажмите кнопку «Обзор», чтобы найти файл.

    • Открыть веб-страницу . Если вы выберете эту опцию, вы выбираете ссылку на веб-адрес. В текстовом поле «Адрес» введите полный адрес веб-сайта, на который ссылка должна направлять зрителей. Чтобы создать ссылку на адрес электронной почты, введите mailto: затем укажите адрес электронной почты. (Обратите внимание, что mailto: это все одно слово.)

    • Пользовательская ссылка . Используйте этот параметр для выбора других типов ссылок в диалоговом окне «Свойства ссылки».

  4. Нажмите «Далее» и следуйте инструкциям в следующем диалоговом окне, прежде чем нажимать «ОК».

Инструмент Link довольно прост в использовании, но вы можете предпочесть создавать ссылки из текста по-другому: с помощью инструмента «Выделение» выберите текст, щелкните правой кнопкой мыши (Windows) или «Control» (Mac) выбранный текст , а затем выберите «Создать ссылку» в появившемся контекстном меню.

При использовании PDF Maker вы можете автоматически переводить ссылки из ваших исходных документов Microsoft Office.

Вы можете редактировать ссылки, выбрав инструмент «Ссылка» и дважды щелкнув ссылку, чтобы открыть диалоговое окно «Свойства ссылки». При редактировании ссылки вы можете изменить способ ее отображения на вкладке «Внешний вид». Сделайте ссылку невидимой или добавьте границу по ссылке. На вкладке «Действия» диалогового окна «Свойства ссылок» вы можете добавлять, редактировать или удалять действия, как это можно сделать с закладками.

Как в PDF сделать гиперссылку

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *